Skip to content

Downgrade pusleaudio 1 cách an toàn

by on 29 Tháng Năm, 2011

Lúc trước hay dùng trục trặc với thằng Pusle lắm lên đến 10.04 thì ổn định lại không gặp lỗi.

Hôm nay mình phải cài libsdl1.2-dev vào thì thằng pulseaudio ko chịu và dodiff nó đòi:

Depends: libpulse0 (=1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu14) but 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu14.1 is to be installed

Nghĩ rằng force version khi downgrade chúng là xong nhưng ai ngờ phải gỡ 1 đống thứ có cả ubuntu-desktop và gnome-panel. Giải quyết = synaptic không được mình tìm trên mạng và ra một giải pháp. Đó là downgrade các gói liên quan đến pulse lại thành hiện trạng ban đầu với lệnh sau (vẫn dùng lệnh install nhưng với dấu /lucid để đưa gói về hiện trạng ban đầu và chú ý phải bao gồm những gói mình nghi ngờ khi gỡ ra sẽ dẫn đến gỡ các thằng khác)

sudo apt-get install pulseaudio/lucid libpulse0/lucid pulseaudio-utils/lucid libpulse-browse0/lucid pulseaudio-esound-compat/lucid libpulse-mainloop-glib0/lucid pulseaudio-esound-compat/lucid pulseaudio-module-bluetooth/lucid pulseaudio-module-gconf/lucid pulseaudio-module-x11/lucid

Thế là xong, không cần phải remove bất kì gói gì cả.

Để lại phản hồi

Gửi phản hồi

Mời bạn điền thông tin vào ô dưới đây hoặc kích vào một biểu tượng để đăng nhập:

WordPress.com Logo

Bạn đang bình luận bằng tài khoản WordPress.com Log Out / Thay đổi )

Twitter picture

Bạn đang bình luận bằng tài khoản Twitter Log Out / Thay đổi )

Facebook photo

Bạn đang bình luận bằng tài khoản Facebook Log Out / Thay đổi )

Google+ photo

Bạn đang bình luận bằng tài khoản Google+ Log Out / Thay đổi )

Connecting to %s